Time zones stripped from calendar appointments

  • I have posted in the Outlook 2013 area, but decided to try here as this problem seems to be caused by the Outlook.com Calendar.


     


    I travel regularly for work, and I keep my calendar using Outlook 2013, synchronized through my Hotmail account.  I make appointments for my travels, including flight times and meeting times, and view / edit them on 3 computers (work, home, travel) and my
    Nokia Windows Phone 8. I rarely use the web calendar.


     


    In Outlook I set the appointment times and time zones for all appointments.


     


    When I synchronize the appointments and view them on another computer using Outlook 2013, the time zone has been stripped from the appointments, and the times are all converted to my current time zone.  So if I set an appointment for 3:00pm in New York,
    when I view it on another computer (or my phone) while I am in California it shows up as 12:00pm. 


     


    This isn't the end of the world, UNTIL I TRAVEL TO A NEW TIME ZONE!  The appointment times stay set to the changed time, without time zone data, so when I fly to New York the sample appointment time still shows as 12:00pm - wrong!


     


    In the past with Hotmail calendar and Outlook 2010 and my old Windows phone 7 this all worked, and the time zones were retained.  But something now strips them out.  The time zone disappears right away when I synchronize Outlook with Live.com.  I have no
    way to tell if Live.com is doing it, or if the synchronization to Windows Phone is stripping the time zone, but somewhere it gets removed and the time shifts as I show above.


     


    I have also tried creating the appointment online in Outlook.com, and specifying the time zones for the appointments there.  It is still stripped off of the appointments.


     


    I really need help with this - I believe it is a bug, but if there is some setting I am missing, please let me know!  It is making my Outlook calendar unusable for travel.


     

  • Thank you for your reply.  I have posted this topic in the forums for Office 2013, Outlook.com, and Windows phone 8.  I need to know if I can contact anyone about it - can no one test this on their computers / phones to see if it also happens to them please?


     


    Create an appointment in Outlook, set the time to another time zone. Save it and synchronize the calendar (send/receive), and close outlook.  Then check it on a Windows Phone 8 device to see what time shows.


     


    Next check Outlook.com to see if there are any time zones showing when you look at the appointment details.  Check the appointment times.


     


    Finally, re-open Outlook, do a send/receive again, and re-check the appointment.  On my computer the times change to my local time zone equivalent, and the time zone field does not show.


     


    Really, I can't tell if this is a problem with my calendar, my phone, or outlook in general, and no one is offering real help, only links to old articles and posts that I have already searched and found.


     


  • What I would do is make an appointment in Outlook in another time-zone, and let it sync to Hotmail/Outlook.com. Now, go to your
    Outlook.com calendar and view full details for this appointment. Check to see if the appointment's time zone is still there.



    I would also double-check that you do not have "sync across time zones" on in Outlook.


  • Entegy, thanks for your response.


     


    You have described just what I have done, create the appointment in Outlook, then check it at Outlook.com (or on my phone) and the time is shifted to the equivalent PDT time, and the time zone does not show.


     


    I cannot find any setting related to "sync across time zones" in Outlook 2013.  I also checked outlook.com and didn't see anything of that sort there.


     


    Can you please try this test also?  Create an appointment in Outlook in another time zone, then check it in your outlook.com calendar?  It might help me to track this down if yours retains the time zone information.  Please also let me know what version
    of Outlook you are using - I did not have this problem with Outlook 2010.


     


    Thanks again.


  • I don't use Outlook or even have it installed right now, so I can't perform the test myself, but I have created appointments that retain their time zone information that sync between Outlook, my phone and Outlook.com.



    IIRC, the "sync across time zones" option in Outlook is next to the time zone selector when you're creating/modifying the appointment.


  • I don't use Outlook or even have it installed right now, so I can't perform the test myself, but I have created appointments that retain their time zone information that sync between Outlook, my phone and Outlook.com.



    IIRC, the "sync across time zones" option in Outlook is next to the time zone selector when you're creating/modifying the appointment.


     


    This is not showing anywhere in Outlook 2013.




    Entegy, it's kind of you to take the time to repond, but please don't - if you are not using Outlook, I don't think you can help me.  At this stage I think I need to connect with a Microsoft employee and make sure they understand this bug.  I have replicated
    it using different calendars and multiple accounts, so it appears to be a bug in their calendaring system.


     


  • Let me try that test for you....I've got Outlook 2013 installed on one of my other computers....I'll test it out and let you know what I see.



  • I ran the following test:



    I live on the East coast & created an appointment, using the Pacific time zone, for 9:00 PT (12:00 ET)

    I created this appointment on my primary computer, which uses Outlook 2010

    I synced the appointment to my Outlook.com account and to my Nokia Lumia 920

    Everything looked good.  The appointment showed up with a 12:00 time.

    Then I synced my tablet, which uses Outlook 2013, to my Outlook.com account

    The time for the appointment shows up as 12:00.  When I click the appointment to view it, it shows the time zone as 9:00 am Pacific Time.




    So everything appears to be working fine for me. 



    So here are some things I think you should try:



    • On Outlook 2013, go verify that the timezone is set properly by going to File > Options > Calendar > scroll down until you see the "Time Zones" section.  On my computer, I have this option set to the Eastern Time zone.  I am not showing a second
      time zone.
    • Return to view your Calendar in Outlook 2013.  Click on one of your appointments to open it up so you can edit it.  Then select Options > click the Time Zones option here to toggle the view to ON. Now you should see the time zone that the appointment
      is set up under.
    • Sync Outlook 2013 to your Outlook.com account
    • Now with your browser go to the Calendar in your Outlook.com account.
    • Click on the calendar entry you just edited in Outlook 2013. Then click the "View details" link on the opened appointment.  Click "Show time zone" (just under the "How long" option). Confirm that the time zone there is correct.



    I hope this helps.....Please post back and let me know how it goes.

     

     

  • Thanks for the test, and the reply.  I do appreciate your taking the time to try this.


     


    I have done exactly what you state multiple times, and each time I do it the time zone vanishes completely.  So in your example, the time is changed to 12:00 ET. I check at Outlook.com and it shows as 12:00 with no time zone, and turning on the time zone
    just comes up Eastern time, and the time stays at 12:00.


     


    My Outlook is set to have multiple time zones - I will try making it only one just to see what that does.


     


    When I go back to Outlook, it shows as 12:00, and I open the appointment and it still shows as 12:00.  At that point with Outlook 2010, when I opened the appointment the time zone would show in the appointment, and the time would be back to the 9:00 time. 


     


    So in my case, the time zone information is being completely stripped from the appointments.


     


     



  • Arghh. Another test, failed.


     


    Office computer: Windows 7, Outlook 2013. I am in Pacific time zone.


    Laptop computer: Windows 8, Outlook 2013.


     


    Outlook options set for Pacific time zone, only 1 time zone shows in Options area.


     


    Created new appointment, central time zone, 11:00am. Saved it.


    Opened it again, time is correct, time zone sho1s.


    Clicked send / receive, then opened it again, still correct.


    Opened Outlook on Windows 8 laptop.


    New appointment appears, I open it. Time zones gone from appointment, time changed to 9:00am.


    Click on Time Zones button, time zones appear with Pacific Time showing.  Closed without saving appointment.


    Close Outlook. Change computer to Central time zone.


    Open outlook, open appointment.  It is on the screen now - appointment time says 9:00, time zone is open and says "Pacific time".  Wow, my head is spinning from this.


     


    Checked on Windows Phone 8.  It shows appointment as 9:00am.  No time zone options there.


     


    What can I do - besides stop using Outlook calendar?


     




  • Thanks for the test, and the reply.  I do appreciate your taking the time to try this.


     


    I have done exactly what you state multiple times, and each time I do it the time zone vanishes completely.  So in your example, the time is changed to 12:00 ET. I check at Outlook.com and it shows as 12:00 with no time zone, and turning on the time zone
    just comes up Eastern time, and the time stays at 12:00.


     


    My Outlook is set to have multiple time zones - I will try making it only one just to see what that does.


     


    When I go back to Outlook, it shows as 12:00, and I open the appointment and it still shows as 12:00.  At that point with Outlook 2010, when I opened the appointment the time zone would show in the appointment, and the time would be back to the 9:00 time. 


     


    So in my case, the time zone information is being completely stripped from the appointments.


     


     







    I don't see "ET" next to the time. I can only see what time zone the time is in if I toggle on the time zone option in Outlook 2013 or if I select the option to view it in Outlook.com.  You're not turning anything on, you're just viewing that field.  If you
    click the down arrow in the timezone view field, you can change the view to Pacific Time (or any other timezone you want to see) and the time will reset to that time zone's time.



    I think the difference between Outlook 2010 and Outlook 2013 is that the timezone field is shown on Outlook 2010 by default (unless you turn the option off altogether). Whereas in Outlook 2013, the timezone field is NOT shown unless you open the appointment
    and toggle it on.  Even then, the timezone field does not stay on...when you exit the appointment, you don't see the field any more.



    So it appears that the default time that is displayed in Outlook 2013 is the first timezone that is displayed under File > Calendar > Timezone.  If you enter a second time zone and then select the "Swap Time Zones" button underneath that, then select the OK
    button.  All the appointments in your calendar switch time to match that time zone.



    When I manually changed the timezone on my phone from Eastern time to Pacific time (as if I had actually traveled there and was sitting in my hotel in Pacific time) the time shifts to 9:00 am. By default, the view of appointment times on the phone is set to
    the time zone the phone is using at the time.



    Maybe I'm getting confused, but I think we're getting the same result here.